Ошибка All com.android.support libraries must use the exact same version specification…

После обновления библиотек зависимостей, например com.android.support:support-v4:25.0.1 до 25.2.0 появляется ошибка:
All com.android.support libraries must use the exact same version specification(mixing versions can lead to runtime crashes). Found versions… Example include com.android.support:support-v4:25.0.1 and com.android.support:percent:25.0.1.

ошибка связана с разными версиями зависимостей в Вашем проекте. Проблема решает за несколько минут. Выполняем во вкладке terminal команду:

 
      gradlew -q dependencies app:dependencies --configuration compile

Где вместо app подставляем имя вашего собираемого модуля.И видим,

com.google.android.gms:play-services-wearable:10.2.0
|    +--- com.google.android.gms:play-services-base:10.2.0
|    |    +--- com.google.android.gms:play-services-basement:10.2.0
|    |    |    \--- com.android.support:support-v4:24.0.0 -> 25.2.0 (*)

что библиотека com.google.android.gms:play-services-basement из зависимостей либы(com.google.android.gms:play-services-wearable) тянет за собой предыдущую версию библиотеки com.android.support:support.

К сожалению проблема в данном случае решится только ручным добавлением библиотеки com.google.android.gms:play-services-basement в скрипт gradle:

 
    compile 'com.android.support:support-v4:25.2.0'
...
    compile 'com.google.android.gms:play-services-basement:10.2.0'

Leave a Reply

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.